Some links are not working properly on the Storenvy admin pages.
Incident Report for Storenvy
Resolved
Issues with the Storenvy admin pages should now be corrected. If you are continuing to have trouble (and clearing your cache and a refresh does not help) please let us know. You can contact us using our contact form or by sending a message to support@storenvy.com. Sorry for the trouble!
Posted Sep 29, 2017 - 16:07 PDT
Identified
We have identified the cause of the issue and it should be corrected soon. We are sorry for the trouble, and thank you for your patience!
Posted Sep 29, 2017 - 15:49 PDT
Investigating
We are currently experiencing issues with some links on the Storenvy admin pages. Some links and tasks are not responding properly when store owners attempt to make changes within their admin account. This includes, but is not limited to variation edits, changes to Extra subscriptions, image uploads, etc. The issue does not appear to effect the ability of customers to purchase from storenvy.com or custom storefronts. We are working on getting this corrected as soon as possible. We are sorry for the trouble, and thank you for your patience!
Posted Sep 29, 2017 - 15:32 PDT