Database Servers are Down
Incident Report for Storenvy
Resolved
The servers are up and running as of 7:33 PM PST.
Posted Jan 13, 2015 - 20:42 PST
Identified
We are experiencing issues with our database servers due to heavy load. We have identified the cause of the issue and are working hard to minimize this downtime.
Posted Jan 13, 2015 - 18:36 PST