Storenvy customer support email issues
Incident Report for Storenvy
Resolved
This issue should now be resolved. Sorry for the trouble!
Posted Oct 12, 2018 - 12:53 PDT
Investigating
We are currently experiencing problems with our internal email support system. The company that provides the service to us is working on correcting it and we hope to have it resolved soon. In the meantime, it is not possible to send an email message to Storenvy support. The Storenvy website should be working normally. This announcement will be updated once the email support system is available again. Sorry for the trouble!
Posted Oct 12, 2018 - 11:54 PDT