Some system emails being delayed up to a couple days
Incident Report for Storenvy
Resolved
Some customer support requests to merchants were delayed up to a week or more due to the outage. These have been recovered and will be going out in the next few hours.
Posted Sep 22, 2014 - 16:14 PDT
Monitoring
The email issues from the past few days were due to a very high level of spam users registering for the site. This caused the email service we use to send "Welcome" email messages to a whole lot of email addresses that hadn't actually registered for Storenvy. This caused high bounce rates and spam reports. Therefore, our email service provider had no choice but to reduce the number of emails we could send per hour.

We rolled out an improvement to our signup experience that has eliminated the ability for spambots to register for Storenvy user accounts. And once again there is peace in the kingdom. Everyone should be getting email normally now, and those emails that have been delayed should start arriving over the next few days.

Thanks for your patience!

Love,
Jon & the Storenvy team
Posted Sep 16, 2014 - 16:01 PDT
Update
We're rolling out some changes today that should eliminate this issue. Thanks for bearing with us!
Posted Sep 15, 2014 - 10:13 PDT
Identified
We're currently addressing an issue with our email service provider that is resulting in some system-generated emails such as "Welcome" messages to be delayed up to a couple of days. We are aware of the issue and working on a solution.
Posted Sep 11, 2014 - 18:56 PDT
This incident affected: The Storenvy Marketplace, Merchant Admin Panel, and The Storenvy Public API.