DNS Issue making the site inaccessible for some users.
Incident Report for Storenvy
Postmortem

This issue was caused by GoDaddy and was not within our control. They were very little help resolving so we ended up switching our DNS which started to resolve the issue but it takes time for the issue to resolve for everyone which is why some report their store is accessible others not yet. Estimated times are within 36hours (from yesterday morning) If anyone really really needs to get into Storenvy and cannot you can manually changing your DNS https://www.google.com/search?client=safari&rls=en... At this point you use google’s DNS servers you should be able to get through.

Preferred: 8.8.8.8 Alternate: 8.8.4.4

Posted Aug 23, 2016 - 09:22 PDT

Resolved
We believe Godaddy was having issues. Some people may not be able to access the site, depending on where your DNS pointed to for requests. Google's servers are giving out proper answers, but others are not. This appears to be solved as we've made adjustments to our DNS.
Posted Aug 22, 2016 - 11:43 PDT