Rolling out new features
Incident Report for Storenvy
Resolved
Things have gotten back to normal, and we'll be restoring missing page elements such as customer payment info in the merchant admin panel shortly.
Posted Oct 12, 2015 - 20:00 PDT
Identified
We are rolling out an awesome new feature which is causing some slowness, we hope to have everything back to normal soon!
Posted Oct 12, 2015 - 16:39 PDT