DDos attack / Site not accessible
Incident Report for Storenvy
Resolved
DDos ended site restored
Posted Oct 22, 2016 - 18:02 PDT
Investigating
We are experiencing a DDos attack that is flooding our site and causing it to be not accessible. I'm sure you've heard similar things about these attacks in the news lately with Amazon , PayPal and Spotify etc. We're working on resolving this. Thank you for your patience.
Posted Oct 22, 2016 - 11:52 PDT